montana 600 usb port- the green death

Got a spanner in the works? Post your motorcycle problems here.
Post Reply
bikenav
Posts: 472
Joined: Mon Jan 28, 2013 11:46 pm
Location: Llanelli
Has thanked: 107 times
Been thanked: 66 times

montana 600 usb port- the green death

Post by bikenav » Mon Dec 02, 2019 6:51 pm

just a note to 600 series users keep an eye on the port on the back of the unit mine has developed a green tinge and now struggling to get a good connection to my computer, the seal appears good, I have no tips for you, anyone else had similar? What is the current situation with Garmins repair/factory replacement procedure, had a 550 replaced many years ago was quite painless then except the shillings of course. I'm not complaining the unit is probably in excess of 5 years old-IMO pretty good kit as most here know I expect.

Adventure Bike Rider New Issue Out Now
byewayrider
Posts: 447
Joined: Fri Nov 29, 2013 3:45 pm
Has thanked: 11 times
Been thanked: 24 times

Re: montana 600 usb port- the green death

Post by byewayrider » Mon Dec 02, 2019 7:18 pm

Give it a coat of acf50 and all will be well... Small dab with a paint brush lol.
Solo ktm690 euro trail rider

User avatar
zimtim
Posts: 2397
Joined: Sun Nov 14, 2010 10:01 am
Has thanked: 520 times
Been thanked: 440 times

Re: montana 600 usb port- the green death

Post by zimtim » Mon Dec 02, 2019 7:51 pm

Green tinge is probably copper oxidation also known as verdigris.
Acetic acid is good for cleaning copper, vinegar on a cotton wool bud or a good electric contact cleaner. Then AFC 50 to keep it clear.

If that fails send it back Garmin, they are really good. Normally send back a refurbished unit as a swap.
Do a quick search on this forum as this has been discussed before.
It is easier to defend yourself against a thousand enemies, than it is to defend against one backstabbing friend

bikenav
Posts: 472
Joined: Mon Jan 28, 2013 11:46 pm
Location: Llanelli
Has thanked: 107 times
Been thanked: 66 times

Re: montana 600 usb port- the green death

Post by bikenav » Mon Dec 02, 2019 8:49 pm

gave it a spray with contact cleaner and then aerosol elecy grease stuff as a cure already, maybe a preventetive would have been wiser, damage already done ? will try the vinegar again though not much to loose now, perhaps try and dump all my data out first if I can get a connection up. Thanks all.

User avatar
zimtim
Posts: 2397
Joined: Sun Nov 14, 2010 10:01 am
Has thanked: 520 times
Been thanked: 440 times

Re: montana 600 usb port- the green death

Post by zimtim » Mon Dec 02, 2019 9:43 pm

It is easier to defend yourself against a thousand enemies, than it is to defend against one backstabbing friend

Post Reply

Return to “TECHNICAL”

Who is online

Users browsing this forum: Google [Bot] and 54 guests