Not happy at all !!!

The Things We Ride
Jelly
Posts: 2636
Joined: Sun May 22, 2011 4:42 pm

Re: Not happy at all !!!

Post by Jelly » Sat Sep 03, 2011 3:35 pm

Sorry to hear about your woes, especially with a brand spanking new bike.

This kind of thing really boils my piss, tell em to poke it up their arse and give your money back straight away, don't give em an easy time.

Good luck with whatever course you take.
"The distant echo of faraway voices boarding far away trains,



To take them home to the ones that they love and who love them forever......."

Adventure Bike Rider New Issue Out Now
ipswichbiker
Posts: 1366
Joined: Wed Sep 29, 2010 8:46 pm

Re: Not happy at all !!!

Post by ipswichbiker » Sat Sep 03, 2011 4:22 pm

Good luck with it either way. I hope you get it sorted without too much hassle
Just out of interest could you show a pic of the broken bit. Ive just had another look at mine. It wiggles off with a bit of effort. Slides on until it wont slide on anymore but no click. Im wondering how yours compares to mine!
I went to the Caribbean on holiday with my wife last year.

Jamaica?

No, she wanted to.




gazxt1200z
Posts: 530
Joined: Wed Mar 16, 2011 9:36 pm
Has thanked: 1 time
Been thanked: 13 times

Re: Not happy at all !!!

Post by gazxt1200z » Sat Sep 03, 2011 4:37 pm

I live in Northampton so was very pleased when i heard that there was a new yamaha shop starting up,wanted to buy my xt1200 from them but didn't like the way they went about their business,bought it elsewhere when i went there to have the 600mile service done they charged me £160 i had a huge bust up with them [should have been £60-70]haven't set foot in the place since.Alf england in bedworth get all my business now they can't do enough for you,I WOULD TAKE IT THERE no questions asked brian will book it in and do it no probs.

minkyhead
Posts: 3982
Joined: Tue Sep 07, 2010 2:31 pm
Has thanked: 302 times
Been thanked: 470 times

Re: Not happy at all !!!

Post by minkyhead » Sat Sep 03, 2011 8:40 pm

im not sure about the clip you refer ..
i checked mine and acfed it and silconed it ...

it may be there ist a different connector mine is a 08 on 09 plate ...it deffo made a resounding click when pressed home


not being a trusting sole i still carry a 600 fazer rectifier as a spare that can be chopped int the loom in a emergancy .. not ideal but it is better than being cought out abroad

i just keep it under the seat with spade clips attached [wrapped in gaffa ]as a precaution ..15k miles on no problems
Image
By minkyhead at 2011-07-19

Image
By minkyhead at 2011-07-19
whats the wether forcast ..wheres me map

Barcelona Pat
Posts: 1076
Joined: Tue Aug 03, 2010 9:06 am
Has thanked: 36 times
Been thanked: 11 times

Re: Not happy at all !!!

Post by Barcelona Pat » Sun Sep 04, 2011 1:48 pm

As people have noted, this is a known fault. I checked mine on purchase, and there is a clear click, but you do have to apply some pressure. Despite it seeming to connect well, I have still ACF'd it and covered the block with a loose tied piece of innertube to keep the worst of the crud away, particularly as I've repositioned the horn.

As recommeded, go to XT660.com and print some of the threads, plus this, plus any other postings where owners have noted this issue. There are quite a few - and hightlight those resolved under warrenty. Returning to your dealer with a fistfull of evidence that this is a Yamaha caused issue - and not a fault of yours - might encourage them to think again about doing it under warrenty. Be polite, but very firm and clear that this issue, and you, are not going away and that it would be in their interest to get it sorted with min fuss. Aside from the XTZ connector issues, there are also XTR loom issues too - so the dealer must have had this before!

I've been out of the UK for a while now, so not sure who are the lead body for consumer protection - but worth a quick check online on UK Gov sites and your local authority one. A couple of calls to them before you return to the dealer - might also lubricate thier behinds into action. Just drop into the conversation that you have already "been in contact with" consumer protection (or whatever their correct name is) regarding your rights.

Hope that helps. Its a great bike. I've done 3k on mine now in the last 3 months, and it is really starting to grow on me. Best of luck.
B)
Pat

Hope that helps

bond_yzf
Posts: 5939
Joined: Fri Aug 19, 2011 3:24 pm
Has thanked: 14 times
Been thanked: 65 times

Re: Not happy at all !!!

Post by bond_yzf » Tue Sep 06, 2011 3:51 pm

well heard back from yamaha today and the harness will be replaced under warranty

Scythian
Posts: 323
Joined: Wed Apr 20, 2011 10:12 pm

Re: Not happy at all !!!

Post by Scythian » Tue Sep 06, 2011 4:01 pm

Funny you should mention this...had a similar problem with my Yamaha and after lots of nagging ended up having it taken to bits under warranty. Then the part holding the lightbulb for the headlight fell to bits and they tried the old chestnut 'you broke it' on me too. Turns out they couldn't be bothered with all the rigmarole of claiming their money back from Yamaha when a problem happens under warranty.

Through forums I've learned that the small Yams being built and assembled in China are having quite a few electrical problems. My alternator also went (again under warranty) after it blew up all the bulbs on a very regular basis. Lately after a long trip to Wales my right indicator fell off...but because I was fed up with the Yam dealer locally I went to Alf England Yamaha in Bedworth. Fantastic service, can't recommend them enough and if you are quick you can have a butchers at a certain Tenere that's recently returned from a Trans-America trip ;)
'The most dangerous part of a motorcycle is the nut connecting the handlebar to the seat.'

bond_yzf
Posts: 5939
Joined: Fri Aug 19, 2011 3:24 pm
Has thanked: 14 times
Been thanked: 65 times

Re: Not happy at all !!!

Post by bond_yzf » Tue Sep 06, 2011 4:30 pm

the harness will be replaced at the dealer who i bought the bike from then i think i will be using Alf England Yamaha from now on cheers for the help/info guys

cheers jim

Scythian
Posts: 323
Joined: Wed Apr 20, 2011 10:12 pm

Re: Not happy at all !!!

Post by Scythian » Wed Sep 07, 2011 12:03 am

bond_yzf wrote:the harness will be replaced at the dealer who i bought the bike from then i think i will be using Alf England Yamaha from now on cheers for the help/info guys

cheers jim
You're welcome. After I started going to Alf England I discovered its where Nick Sanders gets his Tenere sorted.
'The most dangerous part of a motorcycle is the nut connecting the handlebar to the seat.'

bond_yzf
Posts: 5939
Joined: Fri Aug 19, 2011 3:24 pm
Has thanked: 14 times
Been thanked: 65 times

Re: Not happy at all !!!

Post by bond_yzf » Thu Sep 08, 2011 2:33 pm

The dealer rang me today to let me know the parts were in but he tells me they have only sent the actual plug but was told that it would require a complete new harness,I know this sounds weird but I'm a little concerned I think the dealer is pulling a fast one somewhere

Post Reply

Return to “BIKES”

Who is online

Users browsing this forum: Bing [Bot] and 64 guests