Tenere XTZ 600 dash dead intermittently

Got a spanner in the works? Post your motorcycle problems here.
Post Reply
scottnet
Posts: 87
Joined: Sat Feb 11, 2012 11:04 am
Been thanked: 2 times

Tenere XTZ 600 dash dead intermittently

Post by scottnet » Tue Mar 15, 2016 9:00 am

Hi, looking for a steer in the right direction. Just recently when I turn the ignition key on the Tenere nothing happens , and when I turn it off I get some activity on the dash for a second or two. I try a few times and it comes on, a jiggle of the key in the barrel does nothing and because there is activity when I turn it off I don’t suspect the ignition switch .

After a few times it all comes to life and all is well. It seems to be worse when it’s cold

Is it possibly the main relay that has a bad connection or is faulty ?

Any ideas greatly appreciated

Adventure Bike Rider New Issue Out Now
User avatar
DaveCon
Posts: 798
Joined: Fri Jan 16, 2015 10:01 am
Has thanked: 100 times
Been thanked: 99 times

Re: Tenere XTZ 600 dash dead intermittently

Post by DaveCon » Tue Mar 15, 2016 9:03 am

When I had this kind of fault on a Triumph it was a duff battery :(

AndyB
Posts: 8747
Joined: Thu Oct 28, 2010 12:04 pm

Re: Tenere XTZ 600 dash dead intermittently

Post by AndyB » Tue Mar 15, 2016 9:21 am

I'd check the battery terminals before going any further. Disconnect it then clean and grease everything with good quality silicon grease before reconnecting.

After that just go through the wiring harness from switch backwards and keep cleaning/greasing everything as you go. Intermittent faults are always the worst to clear up so good luck with it.

motorbike
Posts: 1671
Joined: Mon Apr 23, 2012 9:02 am
Has thanked: 6 times
Been thanked: 29 times

Re: Tenere XTZ 600 dash dead intermittently

Post by motorbike » Tue Mar 15, 2016 9:22 am

try xt.660 .com they can be very helpfull

bull
Posts: 2481
Joined: Sun Jun 03, 2012 11:21 am

Re: Tenere XTZ 600 dash dead intermittently

Post by bull » Thu Mar 17, 2016 1:20 pm

maybe dirty contacts in the ignition barrel causing problems

scottnet
Posts: 87
Joined: Sat Feb 11, 2012 11:04 am
Been thanked: 2 times

Re: Tenere XTZ 600 dash dead intermittently

Post by scottnet » Thu Mar 17, 2016 1:21 pm

Thanks for all the replies seems like a strip down of the ignition switch is a good place to start

bull
Posts: 2481
Joined: Sun Jun 03, 2012 11:21 am

Re: Tenere XTZ 600 dash dead intermittently

Post by bull » Thu Mar 17, 2016 1:30 pm

well I wouldn't do that just yet, because it might be only something small causing the problem, like a loose or dirty connection or maybe as said already a bad battery etc

Post Reply

Return to “TECHNICAL”

Who is online

Users browsing this forum: No registered users and 55 guests